Instability on US Production Servers
Incident Report for Watershed LRS - US
Resolved
This incident has been resolved
Posted Sep 15, 2020 - 16:02 CDT
Update
We are continuing to monitor and iterate on this morning's fix.
Posted Sep 15, 2020 - 13:29 CDT
Monitoring
A fix has been implemented and we are monitoring results.
Posted Sep 15, 2020 - 10:28 CDT
Investigating
We're currently seeing instability on US Production servers, where some users are experiencing slowness and inability to access the app. We're investigating and working towards a resolution.
Posted Sep 15, 2020 - 08:54 CDT
This incident affected: Web Servers.