US Production Unreachable
Incident Report for Watershed LRS - US
Resolved
We identified the issue and resolved it.
During our routine update an unexpected issue arose. We've logged the issue for resolution and were able to restore service.
Posted Sep 05, 2024 - 17:24 CDT
Investigating
We are currently investigating this issue.
Posted Sep 05, 2024 - 17:08 CDT
This incident affected: Web Servers.